Topics Map > Learning Technology > Canvas

Help! My Canvas Course Dashboard won't load!

This article contains browser information and troubleshooting tips to help resolve browser related Canvas access issues.


Important information for Mac Users

  • Issue: MAC's running OS X older then 10.10 will not display the Canvas website properly.
  • Symptom: Flashing tiles on Canvas Dashboard / Unable to access courses

Browser Information

Safari: Canvas requires Safari version 14 or 15. Note: If you're still running OS X (10.11.6 or earlier), then your going to run into issues. The solution is to upgrade your operating system. Apple has a support page that may help Find out which macOS your Mac is using - Apple Support

Chrome: Canvas requires Chrome 103 or 104 and OS X El Capitan 10.11 or later.

Firefox: Canvas requires Firefox 103 or 104 and Firefox supports older Mac operating systems.


Supported Browsers

Instructure products support the current and previous major releases of the following browsers:

  • Chrome 103 and 104
  • Firefox 103 and 104 (Extended Releases are not supported*)
  • Edge 103 and 104
  • Safari 14 and 15 (Macintosh only)

To find out more about Instructure's computer and browser requirements, see the following Canvas Guide:

You can verify that the browser you are currently using is up to date by using the browser checker tool in the step below.




Keywords:canvas dashboard access course Mac   Doc ID:120392
Owner:Linda W.Group:UW Parkside
Created:2022-08-09 10:12 CDTUpdated:2022-09-08 16:02 CDT
Sites:UW Parkside
Feedback:  3   1